Автор Тема: livecd-tools неправильно делает загрузочную флэшку  (Прочитано 2257 раз)

Бим

  • Newbie
  • *
  • Сообщений: 15
    • Просмотр профиля
На первом винчестере стоит CentOS 5.5, и имеется пакет livecd-tools с программой livecd-iso-to-disk . Прога нормально делает загрузочные флэшки из подготовленного образа.
На том же ПК заменил винт с CentOS той же версии, куда установил этот же пакет  из rpm. Версия livecd-iso-to-disk-014-8.el5.rf . Скопировал все образы с первого винта на второй и загрузился со второго. Но когда запускаю  livecd-iso-to-disk , неправильно создается флэшка. Если на первом винте кроме директорий /LiveOS и, конечно же, /lost&found создается третья директория /syslinux, то на операционке со второго винта утилита этой директории не создает, а все ее содержимое кидается в корень флэшки. Соответственно она делается не загрузочная (хотя флаг бута установлен parted-ом - также как делал и на первом ПК).
Я уж даже скопировал все файлы с первого винта, начинающиеся на "live-cd" (а они все в директории /usr), все безрезультатно. Версия livecd-tools последняя, версия  syslinux на втором винте тоже последняя (syslinux-3.11-4.i386)

Никак не пойму, что вызывает эту проблему. Кто-нибудь знает?
« Последнее редактирование: Февраль 15, 2012, 01:30:24 pm от Бим »

Бим

  • Newbie
  • *
  • Сообщений: 15
    • Просмотр профиля
Re: livecd-tools неправильно делает загрузочную флэшку
« Ответ #1 : Февраль 15, 2012, 02:51:29 pm »
Все выяснилось. Оказывается, образы сделаны с использованием  сислинукса более ранней версии.